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1 Introduction 
 

1.1 About this Manual 
 

1.1.1 Short Description 
The configuration software described here is a FDT frame application to 
configure communication-capable fieldbus devices of different 
manufacturers in one project. 

In accordance with the FDT Specification 1.2 (Field Device Tool 
Specification) the configuration software is used as a frame application for 
DTM (Device Type Manager), which are provided by the field device 
manufacturers. 

Via the communication channel (Master DTM) the communication with the 
field devices is set up. The field devices use protocols as e. g. PROFIBUS. 
 

1.1.2 Overview 
The table below gives an overview of the descriptions provided in this 
manual: 
 

Section Subsection Manual  
Page 

Menus The Menu Bar 10 

 Toolbars 10 

How to use Start Program 14 

 Create New Project / Open Existing Project 16 

 Save Projects 17 

 User Management 17 

 Select Program Language 19 

Table 1: Overview 

 

1.1.3 Online Help 
The frame application contains an integrated online help facility. 

 To open the online help, click on the Help button or press the F1 key. 
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1.1.4 List of Revisions 
Index Date Version Chapter Revision 
13 17-02-24 1.2000 1.4   Section System Requirements,Internet access added, Windows 

8.1 and Windwos 10 added. 

14 18-02-16 1.2000     Versioning information revised (title page and this section).  
 
 

1.1.5 Conventions in this Manual 

Notes, operation instructions and results of operation steps are marked as 
follows: 

Notes 
 
 

 

Important: <important note you must follow to avoid malfunction> 

 

 

Note:  <general note> 

 

 

<note, where to find further information> 

 

Operation Instructions 
 

1. <instruction> 

2. <instruction> 
 

or 
 

 <instruction> 

 

Results 
 

 <result> 
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1.2 Legal Notes 
 

Copyright 
© Hilscher Gesellschaft für Systemautomation mbH 

All rights reserved. 

The images, photographs and texts in the accompanying materials (in the 
form of a user's manual, operator's manual, Statement of Work document 
and all other document types, support texts, documentation, etc.) are 
protected by German and international copyright and by international trade 
and protective provisions. Without the prior written consent, you do not 
have permission to duplicate them either in full or in part using technical or 
mechanical methods (print, photocopy or any other method), to edit them 
using electronic systems or to transfer them. You are not permitted to make 
changes to copyright notices, markings, trademarks or ownership 
declarations. Illustrations are provided without taking the patent situation 
into account. Any company names and product designations provided in 
this document may be brands or trademarks by the corresponding owner 
and may be protected under trademark, brand or patent law. Any form of 
further use shall require the express consent from the relevant owner of the 
rights. 

Important notes 
Utmost care was/is given in the preparation of the documentation at hand 
consisting of a user's manual, operating manual and any other document 
type and accompanying texts. However, errors cannot be ruled out. 
Therefore, we cannot assume any guarantee or legal responsibility for 
erroneous information or liability of any kind. You are hereby made aware 
that descriptions found in the user's manual, the accompanying texts and 
the documentation neither represent a guarantee nor any indication on 
proper use as stipulated in the agreement or a promised attribute. It cannot 
be ruled out that the user's manual, the accompanying texts and the 
documentation do not completely match the described attributes, standards 
or any other data for the delivered product. A warranty or guarantee with 
respect to the correctness or accuracy of the information is not assumed. 

We reserve the right to modify our products and the specifications for such 
as well as the corresponding documentation in the form of a user's manual, 
operating manual and/or any other document types and accompanying 
texts at any time and without notice without being required to notify of said 
modification. Changes shall be taken into account in future manuals and do 
not represent an obligation of any kind, in particular there shall be no right 
to have delivered documents revised. The manual delivered with the 
product shall apply. 

Under no circumstances shall Hilscher Gesellschaft für Systemautomation 
mbH be liable for direct, indirect, ancillary or subsequent damage, or for 
any loss of income, which may arise after use of the information contained 
herein. 

Liability disclaimer 
The hardware and/or software was created and tested by Hilscher 
Gesellschaft für Systemautomation mbH with utmost care and is made 
available as is. No warranty can be assumed for the performance or 
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flawlessness of the hardware and/or software under all application 
conditions and scenarios and the work results achieved by the user when 
using the hardware and/or software. Liability for any damage that may have 
occurred as a result of using the hardware and/or software or the 
corresponding documents shall be limited to an event involving willful intent 
or a grossly negligent violation of a fundamental contractual obligation. 
However, the right to assert damages due to a violation of a fundamental 
contractual obligation shall be limited to contract-typical foreseeable 
damage. 

It is hereby expressly agreed upon in particular that any use or utilization of 
the hardware and/or software in connection with 

• Flight control systems in aviation and aerospace; 

• Nuclear fusion processes in nuclear power plants; 

• Medical devices used for life support and 

• Vehicle control systems used in passenger transport 

shall be excluded. Use of the hardware and/or software in any of the 
following areas is strictly prohibited: 

• For military purposes or in weaponry; 

• For designing, engineering, maintaining or operating nuclear systems; 

• In flight safety systems, aviation and flight telecommunications systems; 

• In life-support systems; 

• In systems in which any malfunction in the hardware and/or software 
may result in physical injuries or fatalities. 

You are hereby made aware that the hardware and/or software was not 
created for use in hazardous environments, which require fail-safe control 
mechanisms. Use of the hardware and/or software in this kind of 
environment shall be at your own risk; any liability for damage or loss due 
to impermissible use shall be excluded. 

Warranty 
Hilscher Gesellschaft für Systemautomation mbH hereby guarantees that 
the software shall run without errors in accordance with the requirements 
listed in the specifications and that there were no defects on the date of 
acceptance. The warranty period shall be 12 months commencing as of the 
date of acceptance or purchase (with express declaration or implied, by 
customer's conclusive behavior, e.g. putting into operation permanently). 

The warranty obligation for equipment (hardware) we produce is 36 
months, calculated as of the date of delivery ex works. The aforementioned 
provisions shall not apply if longer warranty periods are mandatory by law 
pursuant to Section 438 (1.2) BGB, Section 479 (1) BGB and Section 634a 
(1) BGB [Bürgerliches Gesetzbuch; German Civil Code] If, despite of all 
due care taken, the delivered product should have a defect, which already 
existed at the time of the transfer of risk, it shall be at our discretion to 
either repair the product or to deliver a replacement product, subject to 
timely notification of defect. 

The warranty obligation shall not apply if the notification of defect is not 
asserted promptly, if the purchaser or third party has tampered with the 
products, if the defect is the result of natural wear, was caused by 
unfavorable operating conditions or is due to violations against our 
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operating regulations or against rules of good electrical engineering 
practice, or if our request to return the defective object is not promptly 
complied with. 

Costs of support, maintenance, customization and product care 
Please be advised that any subsequent improvement shall only be free of 
charge if a defect is found. Any form of technical support, maintenance and 
customization is not a warranty service, but instead shall be charged extra. 

Additional guarantees 
Although the hardware and software was developed and tested in-depth 
with greatest care, Hilscher Gesellschaft für Systemautomation mbH shall 
not assume any guarantee for the suitability thereof for any purpose that 
was not confirmed in writing. No guarantee can be granted whereby the 
hardware and software satisfies your requirements, or the use of the 
hardware and/or software is uninterruptable or the hardware and/or 
software is fault-free. 

It cannot be guaranteed that patents and/or ownership privileges have not 
been infringed upon or violated or that the products are free from third-party 
influence. No additional guarantees or promises shall be made as to 
whether the product is market current, free from deficiency in title, or can be 
integrated or is usable for specific purposes, unless such guarantees or 
promises are required under existing law and cannot be restricted. 

Confidentiality 
The customer hereby expressly acknowledges that this document contains 
trade secrets, information protected by copyright and other patent and 
ownership privileges as well as any related rights of Hilscher Gesellschaft 
für Systemautomation mbH. The customer agrees to treat as confidential all 
of the information made available to customer by Hilscher Gesellschaft für 
Systemautomation mbH and rights, which were disclosed by Hilscher 
Gesellschaft für Systemautomation mbH and that were made accessible as 
well as the terms and conditions of this agreement itself. 

The parties hereby agree to one another that the information that each 
party receives from the other party respectively is and shall remain the 
intellectual property of said other party, unless provided for otherwise in a 
contractual agreement. 

The customer must not allow any third party to become knowledgeable of 
this expertise and shall only provide knowledge thereof to authorized users 
as appropriate and necessary. Companies associated with the customer 
shall not be deemed third parties. The customer must obligate authorized 
users to confidentiality. The customer should only use the confidential 
information in connection with the performances specified in this 
agreement. 

The customer must not use this confidential information to his own 
advantage or for his own purposes or rather to the advantage or for the 
purpose of a third party, nor must it be used for commercial purposes and 
this confidential information must only be used to the extent provided for in 
this agreement or otherwise to the extent as expressly authorized by the 
disclosing party in written form. The customer has the right, subject to the 
obligation to confidentiality, to disclose the terms and conditions of this 
agreement directly to his legal and financial consultants as would be 
required for the customer's normal business operation. 
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Export provisions 
The delivered product (including technical data) is subject to the legal 
export and/or import laws as well as any associated regulations of various 
countries, especially such laws applicable in Germany and in the United 
States. The products / hardware / software must not be exported into such 
countries for which export is prohibited under US American export control 
laws and its supplementary provisions. You hereby agree to strictly follow 
the regulations and to yourself be responsible for observing them. You are 
hereby made aware that you may be required to obtain governmental 
approval to export, reexport or import the product. 
 

 

1.3 Registered Trademarks 
Windows® XP, Windows® Vista, Windows® 7, Windows® 8, Windows® 8.1 
and Windows® 10 are registered trademarks of Microsoft Corporation. 

All other mentioned trademarks are property of their respective legal 
owners. 

 

 

1.4 System Requirements 
 
 

• PC with 1 GHz processor or higher 

• Windows® XP SP3,  
Windows® Vista (32-Bit) SP2,   
Windows® 7 (32-Bit and 64-Bit) SP1,   
Windows® 8 (32-Bit and 64-Bit),  
Windows® 8.1 (32-Bit and 64-Bit),   
Windows® 10 (32-Bit and 64-Bit) 

• Administrator privilege required for installation 

• Internet Explorer 5.5 or higher 

• RAM: min. 512 MByte, recommended 1024 MByte 

• Graphic resolution: min. 1024 x 768 pixel 

• Keyboard and Mouse 

• Restriction: Touch screen is not supported. 
 

 

Note: If the project file is used on a further PC,  

 this PC must also comply with the above system requirements, 

 the device description files of the devices used in the project must be 
imported into the configuration software SYCON.net on the new PC, 

 and the DTMs of the devices used in the project must also be installed 
on that further PC. 

 
 

 

 



Windows and Menus 10/23 

SYCON.net | Frame Application  
DOC040402OI14EN | Revision 14 | English | 2018-03 | Released | Public  © Hilscher, 2004-2018 

2 Windows and Menus 
2.1 Output Window 

The Output Window contains index cards, which indicate:  

• Information, warnings and error messages in plain text. 

• The numbers of the index card are installation qualified.  

 
Figure 1: Output Window 

The following icons can be found in the Output Window above. They 
symbolize the failure class. 
 

 
Icon appears if an important failure is detected. 

 
Icon appears in case of a warning. 

 
Used for informational purposes. 

 
Program step was executed without failure. 

 
Program step was executed with a fatal fault; task following 
the icon did not complete. 

 
 

 
Note:  The executed program task is described in the Output Window 
besides the icon. 

 

2.2 The Menu Bar 
The menu bar of the configuration software contains pull down menus, via 
which all available program functions can be called up. 

 
Figure 2: Menu bar 

 

 
Note:  The two menus Device and Network are not a function of the 
frame application, but dynamic menus of the FDT of container netDevice. 
That means these menus are only faded in the menu bar, if the windows 
netProject or netDevice of the FDT container are activated. 
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2.2.1 File 
The File menu contains functions for working on projects. 

 
Figure 3: Menu File 

 

Menu Meaning 
New Creates a new project. At least the User Rights (described on page 20) of maintenance 

are necessary. 
Open Opens an existing project. 
Close Closes the actual opened project. If changes are not stored yet, a dialog appears which 

requests the user to save the project before closing. 
Save Saves the actual configuration. Therefore at least the User Rights (described on page 

20) of maintenance are necessary. 
Save As Saves the project file with a new name. Therefore at least the User Rights (described on 

page 20) of maintenance are necessary. 
Exit Closes the program. If changes of the project file are not stored yet, a dialog appears 

which requests the user to save the project before ending. 

Table 2: Menu File 

 

 
Note: The button Project is only enabled, if projects were already stored. 
If there are still no projects available on the system the button is disabled. 
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2.2.2 View 
The frame application offers several possibilities for the arrangement and 
representation of the projects. In the menu View the individual tool bars 
and windows can be faded in and/or out. 

Actual indicated tool bars and/or windows are marked in the View menu by 
a checkmark. 
 

 
Note: The representation in the menu View is dynamic. That means it 
depends on the components which were installed during installation. 

 

 

2.2.3 Extra 
The menu Extra contains functions for the program settings of the frame 
application. These settings are stored when closing the software and called 
up again during the next program start. 

 
Figure 4: Menu Extra 

 

Menu Meaning 
User Management Opens a dialog window for setting-up, changing and deletion of users. In section User 

Management on page 18 you find detailed information about the user management. 

Language Opens a dialog window for changing the programming language. Further information for 
changing the programming language you find in section Select Program Language on page 
19. 

Table 3: Menu Extra 
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2.2.4 Help 
The menu Help contains both the documentation about the frame 
application as well as general information about the software and a 
reference to the homepage of the manufacturer. 

 
Figure 5: Menu Help 

 

Menu Meaning 
Content and Index Opens the documentation of the frame application. 
About Information about the program version. 

Table 4: Menu Help 

 

2.2.4.1 About 

Shows the version of the frame application. 
 

Menu Meaning 
Component Displays installed components, including version and path. 
Support Opens a list of contact details of the subsidiaries. 
Systeminfo Provides technical data on the operating system. 
Ok Closes the About window. 

Table 5: Menu About 
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2.3 Toolbars 
Frequently used menu functions are united in toolbars: 

2.3.1 Standard Toolbar 
The Standard toolbar contains the functions (from left to the right)  

• File > New,  

• File > Open,  

• File > Save and 

• Help > Info  
It is displayed or hidden via the menu View > Standard. 

 
Figure 6: Standard Toolbar 

 

2.3.2 Preset Toolbar 
The Preset toolbar gives the possibility to call up to four different 
representations variants for a project. 

The respective representation is always stored in the active view. The last 
representation in the respective view is called up by selecting another 
representation. 

 
Figure 7: Preset Toolbar 

 

 A right click on the Preset toolbar allows changing different view of the 
open project 
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2.3.3 Network Toolbars 
It is possible that toolbars from further installed components are displayed 
in the frame application.  

For example the frame application indicates a network toolbar, which is 
displayed and/or hidden via the menu View > Network, if the netDevice 
component is installed.  

The toolbar Network contains the functions (from left to the right): 

• Network > Add busline,  

• Network > Delete last busline and 

• Network > Device Catalog  

 
Figure 8: Network Toolbar 

 

 
Note: The Network toolbar is enabled, if the focus is put on the 
netDevice or netProject window. 

 

2.3.4 Debug Toolbar 
 

 
Note: The menu entries for the debug mode are only available, if the 
debug mode is supported by the frame application and the Master DTM. 

 

The debug toolbar is faded in and faded out via the menu View > Debug.  

This toolbar contains the functions (from the left to the right): 

• Debug > Start Project Debug Mode,  

• Debug > Stop Project Debug Mode 

    
Figure 9: Debug Toolbar - Start Project Debug Mode 

 
Figure 10: Debug Toolbar - Stop Project Debug Mode 
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3 Working with the Frame Application 
3.1 Start Program 

Start the frame application via the corresponding program entry in Start > 
Programs. The following dialog window opens: 

 
Figure 11: Start Program - User Registration 

 

Select the User Name in the pull down menu and enter the Password. 
Confirm this with OK. 
 

 
Note:  With the first program start a request appears, to type in a 
password for the administrator. This password must be confirmed by 
entering it again. This password can be changed by the administrator with 
the menu Extra > User Management. 

 
 

 
Note:  Please note, that the capitalization of the password is important for 
the login! 

 

In case of successful registration the software is started, otherwise the 
following error message appears: 

 
Figure 12: Registration has failed 

 

 
Note: In the dialog window of the User Management further users can be 
created. Here it must be considered that the user management can be 
called only by the Administrator. Further information about this you find 
in section User Management on page18. 
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3.2 Create New Project / Open Existing Project 

A new project is created via the menu File > New or by clicking the  
symbol in the toolbar. Now the menus are selectable. 

With the menu File > Open or respectively via the symbol  in the toolbar 
an already existing project is opened. The existing projects are indicated in 
the dialog window and the project which should be opened can be selected 
by clicking on it. 

3.3 Save Projects 

Via the menu File > Save or File > Save as or via the symbol  a project 
can be saved. 

If the program is exit and the current configuration does not agree with the 
last saved configuration, the following question appears: 

 
Figure 13: Security Question - Save Project 

 

If you answer this question with Yes, the project data are stored. If you 
answer this question with No, the changed project data are rejected. 

The saving procedure is aborted by clicking the Chancel button and the 
project data is not stored. 
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3.4 User Management 
The privileges and right for individual users are specified by the User 
Management. Via the menu Extra > User Management the user 
administration is called up. 
 

 
Note: Only the Administrator has the authorization to call up the user 
administration, to install new users or to edit existing user data. The other 
users do not have administrative laws. Thus the menu of the user 
administration is grayed out for these users and disabled. 

 

 

3.4.1 Install User 
The user Administrator is pre-defined and disabled. However the 
Password for the administrator can be changed. 

By selecting the individual pre-defined users Planning Engineer, 
Maintenance, Operator and respectively Observer the respective users 
are created. The created users are indicated in the pull down menu User 
Name of the user login. 

 
Figure 14: Extra > User Management 

 

In section User Rights on page 20 you find an overview of the several users 
with their respective rights. 

 

3.4.2 Delete User 
By checking off the check box in front of the user name an existing user is 
deleted. The deleted user is not longer available in the pull-down menu in 
the login dialog. 
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3.4.3 Change Password 
Via the Password button in the line of the respective user right a password 
can be assigned to each individual user group. 

 
Figure 15: Change password 

 

 
Note:  Please note, that the capitalization of the password is important for 
login! 

 

 

3.5 Select Program Language 
The menu Extra > Options opens the following dialog for selecting the 
program language: 

 
Figure 16: Select Program Language 

 

Select the desired language from the list field by clicking on it and confirm 
this selection with OK. 

You are requested to the program again, that the change is taken over. 
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4 Appendix 
4.1 User Rights 

Apart from the administrator, which has full rights of access, there are four 
further user levels, which have different rights of access in each case: 
 

Action Observer Operator Maintenance Planning 
Engineer 

File 
   New No No Yes Yes 

   Open Yes Yes Yes Yes 

   Close Yes Yes Yes Yes 

   Save No No Yes Yes 

   Save As No No Yes Yes 

   Exit Yes Yes Yes Yes 
View 
   (any) Yes Yes Yes Yes 
Extra 
   User Management No No No No 

   Options Yes Yes Yes Yes 

Table 6: User Rights 

 

4.2 References 
[1] Device Type Manager (DTM) Style Guide, Version 1.0 ; FDT-JIG - Order No. 

<0001-0008-000> 
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4.5 Glossary 
DTM 

Device Type Manager. 

The Device Type Manager (DTM) is a software module with graphical user 
interface for the configuration or for diagnosis of device. 

FDT 

Field Device Tool 

FDT specifies an interface, in order to be able to use DTM (Device Type 
Manager) in different applications of different manufacturers.  
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4.6 Contacts 
 

Headquarters 
 
Germany 
Hilscher Gesellschaft für  
Systemautomation mbH 
Rheinstrasse 15 
65795 Hattersheim 
Phone: +49 (0) 6190 9907-0 
Fax:     +49 (0) 6190 9907-50 
E-Mail: info@hilscher.com 
Support 
Phone: +49 (0) 6190 9907-99 
E-Mail: de.support@hilscher.com 
 

 
 
 
 
 
 
 
 
 
 
 
 

Subsidiaries 
 

 

China 
Hilscher Systemautomation (Shanghai) Co. Ltd. 
200010 Shanghai 
Phone: +86 (0) 21-6355-5161 
E-Mail: info@hilscher.cn 
Support 
Phone: +86 (0) 21-6355-5161 
E-Mail: cn.support@hilscher.com 
 
France 
Hilscher France S.a.r.l. 
69500 Bron 
Phone: +33 (0) 4 72 37 98 40 
E-Mail: info@hilscher.fr 
Support 
Phone: +33 (0) 4 72 37 98 40  
E-Mail: fr.support@hilscher.com 
 
India 
Hilscher India Pvt. Ltd. 
Pune, Delhi, Mumbai 
Phone:  +91 8888 750 777 
E-Mail: info@hilscher.in 
 
Italy 
Hilscher Italia S.r.l. 
20090 Vimodrone (MI) 
Phone: +39 02 25007068 
E-Mail: info@hilscher.it 
Support 
Phone: +39 02 25007068 
E-Mail: it.support@hilscher.com 

Japan 
Hilscher Japan KK 
Tokyo, 160-0022 
Phone: +81 (0) 3-5362-0521 
E-Mail: info@hilscher.jp 
Support 
Phone: +81 (0) 3-5362-0521 
E-Mail: jp.support@hilscher.com 
 
Korea 
Hilscher Korea Inc. 
Seongnam, Gyeonggi, 463-400 
Phone: +82 (0) 31-789-3715 
E-Mail: info@hilscher.kr 
 
Switzerland 
Hilscher Swiss GmbH  
4500 Solothurn 
Phone: +41 (0) 32 623 6633 
E-Mail: info@hilscher.ch 
Support 
Phone: +49 (0) 6190 9907-99 
E-Mail: ch.support@hilscher.com 
 
USA 
Hilscher North America, Inc.  
Lisle, IL 60532 
Phone: +1 630-505-5301 
E-Mail: info@hilscher.us 
Support 
Phone: +1 630-505-5301 
E-Mail: us.support@hilscher.com 
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